home *** CD-ROM | disk | FTP | other *** search
/ Aminet 30 / Aminet 30 (1999)(Schatztruhe)[!][Apr 1999].iso / Aminet / dev / basic / Crazy8.src.lha / Scource / NewSetLocale.bb < prev    next >
Text File  |  1998-08-12  |  3KB  |  94 lines

  1. ;card set selector
  2. ;Curt Esser
  3. ;camge@ix.netcom.com
  4. ;last modified 4/18/98
  5. WBStartup
  6. WBenchToFront_
  7. v$="$VER: Crazy8.card.selector v2.6a (4/98) by Curt Esser"
  8. MaxLen pa$=192          ;needed for file requestor
  9. MaxLen fi$=192
  10. pa$="Cards"            ;default path
  11.  
  12. SetErr                  ;in case the program is moved
  13.   Request "Error!","Put this program in|the Crazy 8's drawer|and try again!"," OK "
  14.   End
  15. End SetErr
  16. LoadPalette 0,"cards/3d.deck"    ;load the palette
  17. ClrErr
  18.  
  19. ScreenPens 2,4,6,7,1,3,1                ;fix requestor colours
  20. BitMap 0,320,220,3                      ;open bitmap & screen & window
  21. BitMap 1,320,200,3                      ;this for the window
  22. Screen 0,0,0,320,220,3,0,"Crazy 8 Cardset Selector",0,1,0
  23. MenusOff
  24. Use Palette 0
  25. Window 0,0,15,320,200,$0800|$100|$1000,"",0,1
  26. CatchDosErrs
  27.  
  28. Repeat
  29. .getpic
  30.   fi$="Click on Cancel to Exit"           ;default file name
  31.  
  32.   ;OK - get the name of a picture file
  33.  
  34.   cardpic$= ASLFileRequest$ ("Select a Crazy8's Card Set",pa$,fi$,0,12,320,188)
  35.   If cardpic$="" Then End
  36.   If Exists (cardpic$)
  37.     ILBMInfo cardpic$                       ;check the picture
  38.     If ILBMWidth<>320 OR ILBMHeight<>200 OR ILBMDepth<>3       ;not even the right size!
  39.       er$=fi$+"|Non-standard picture size!|Please try again!"
  40.       Request "Picture Error!",er$,"aaarrrgghhh!"
  41.       Goto getpic                           ;so try again
  42.     EndIf
  43.   Else
  44.     End
  45.   EndIf
  46.  
  47.   LoadBitMap 1,cardpic$                    ;load the pic
  48.  
  49.   ;Use Palette 0                           ;and use game palette
  50.   BitMaptoWindow 1,0
  51.  
  52.   ;now ask 'em if it's the right one
  53.  
  54.   answer=(Request ("Please Confirm:","OK to use this|set of cards?"," Yes | No! "))
  55.  
  56. Until answer=1                            ;if no, go try again
  57. Use BitMap 1
  58.  
  59. For shp=0 To 57                           ;OK, grab the shapes
  60.   GetaShape shp,column,row,24,32
  61.   MidHandle shp
  62.   column+25
  63.   If column>250
  64.     column=0
  65.     row+33
  66.   EndIf
  67. Next shp
  68.  
  69. ;ready to save the shapes, but set an error trap first!
  70.  
  71. SetErr
  72.   Request "Save Error!","Unable to save|the Card File"," Oh, NO! "
  73.   End
  74. End SetErr
  75.  
  76. SaveShapes 0,52,"data/card.shapes"       ;first the cards
  77.  
  78. LoadShapes 58,"data/gad.shapes"          ;now we need to update the
  79.                                          ;gadget shape file too
  80. For i=64 To 68                           ;by copying in the new
  81.   Free Shape i                           ;shapes grabbed from the pic
  82.   CopyShape i-11,i
  83. Next
  84.  
  85. SaveShapes 58,69,"data/gad.shapes"       ;and save them too
  86.  
  87. Request "OK!","All Done!"," Great! "     ;that's it!
  88. VWait 50
  89. ClrErr
  90. VWait 50
  91. End
  92.  
  93.  
  94.